タスクマネージャーの表示がフリーズ。状況とフリーズしたように見える一因

Windows 10を長時間利用していると、あるいはPCを購入するたびに、重大な不具合まではいかなくても新たなエラー、新たな現象が生じているように感じます。

今回生じた現象は、タスクマネージャーの表示のフリーズ、あるいはフリーズしたように見える現象。CPUやメモリの資料率が変動しない状況です。タスクマネージャーから起動したリソースモニターでは、CPUやメモリの使用率は変動しており、PC自体に大きな影響はないと思われるのですが、タスクマネージャーのプロセス表示はフリーズしたままとなっていました。

読者の方の情報では、タスクマネージャーがフリーズしたように見える一因は、タスクマネージャーの更新頻度が一時停止になっていた事例もあるようです。

スポンサーリンク

タスクマネージャーのプロセス表示がフリーズした状況

解決策を見出したものではありませんが、タスクマネージャーのプロセス表示がフリーズした状況と、PCの操作には影響がないことの記載です。

 

▼タスクマネージャーを起動直後の画像。

2画像のみ掲載しましたが、タスクマネジャーをいつ開いても30%以上もCPUを利用している状況。今回、このTask Manager自体のCPU使用率が高いことを確認する過程で、タスクマネージャーの表示がフリーズしていることが発覚

 

モニターをずっと見ていても以下の状況が続きます。

  • 普段ならプロセスの状況が刻一刻と動くのですが、変化がない状況。右クリックの「タスクの終了」は稼働します。
  • 上記画像のタスクマネージャーのCPU使用率も高いまま変化しません。ただし、タスクマネージャーを再起動すると、CPU使用率は変わっています。

 

▼「何か変だぞ」と「プロセス」を見てみると、グラフが全く動かない。そして、他のPCのタスクマネージャーを確認したところ、「Task Manager」のCPU使用率は、タスクマネージャー起動直後の瞬間的には高いものの、すぐに1%前後に落ち着きます。

ここで、今回エラーが生じているタスクマネージャーの状況は、CPUの使用率が高いままであること、グラフが全く動かないことより、タスクマネージャー起動直後にプロセス表示が動いていないことが判明

 

▼そこで「リソースモニター」を起動してみると、Task ManagerのCPU使用率、全体のCPU使用率は低位安定しており、負荷をかけるとすぐ反応することより、正常に動いています。

やはり、タスクマネージャーの表示が動いていないようです。

 

今回の状況を再度整理すると以下となります。

  • タスクマネージャー起動直後に、プロセス表示がフリーズし、CPU、メモリ使用率が変化しない。
  • タスクマネージャー起動直後のCPU使用率はかなり高く、大きなエラーが生じていると勘違い。
  • ただし、リソースモニターで確認すると、CPU、メモリ使用率も変動。PCを操作してもおかしな挙動、レスポンスの悪化はありまさん。

フリーズしたように見える一因は、更新の頻度の一時停止

すっかり記事を更新することを失念していましたが、この記事をご覧になった方からの情報では、フリーズしたように見える一因・事例として、何かのトリガーで(トリガーは未確認)タスクマネージャーの「更新の頻度」が「一時停止」となることもあるようです。

 

▼タスクマネージャーの「表示」「更新の頻度」に「一時停止」の項目があります。「一時停止」となっていた場合には、タスクマネージャーがフリーズしたように見えて当然となります。

 

がしかし、昨日(2018年8月5日)、またもや同端末でタスクマネージャーがフリーズ。スクショ・深追いを失念しましたが、明らかに更新の頻度を一時停止していたものではなく、別の要因があることも確かです。

まとめ

今回の現象で、タスクマネージャーのプロセス表示のみがフリーズし(フリーズしたように見える)、PC内部の状態は正常であることの確認に3時間ほど費やしてしまいました。

フリーズしたように見える一因としては、タスクマネージャーの「更新の頻度」を「一時停止」していたこともあるようですが、私の事例では別の要因とも思え、未解決のままとなっています。

 

コメント

  1. kkk より:

    私も同じ状況になりましたが、解決しました。
    まず、タスクマネージャ起動→メニューの表示→更新の頻度→一時停止から通常
    にする。
    要は一時停止になってたからフリーズしてたわけですね。

    • kenken より:

      貴重な情報ありがとうございます。確かに、「更新の頻度」に「一時停止」の項目がありますね。
      どのタイミングで一時停止になっていたのか不明ですが、これが原因とのことで納得。
      後ほど、記事を修正させていただきます。